WordPress 3.6: Umlaute im Titel ohne Plugin entschärfen

Bis jetzt war es immer notwendig, dass man zum Beispiel ein Plugin installiert um die Ausgabe der deutschen Umlaute im Titel zu “entschärfen” (ae aus ä), da WordPress standardmäßig aus ß nur s und aus ö nur o macht. So wird aus dem Artikel-Titel Schöne Grüße aus Köln in der URL /schone-gruse-aus-koln/ anstatt /schoene-gruesse-aus-koeln/ wie es sinnvoll wäre.

Ab WordPress 3.6 wird der Einsatz von Plugins nicht mehr notwendig sein, wie man auch an der Datei /wp-includes/formatting.php sehen kann:

WordPress 3.6: Umlaute ohne Plugin

Es reicht wenn man in der wp-config.php unter der Sprachangabe folgendes notiert: define('WPLANG', 'de_DE');. Die deutsche sprachdatei muss nicht vorhanden sein und es muss auch nicht das deutsche Paket sein. Die Umlautentschärfung ist dann automatisch aktiviert:

WordPress 3.6: Umlaute entschärft

Diesen Blogartikel teilen:

Vladimir

Vladimir Simović arbeitet seit 2000 mit HTML & CSS und seit Januar 2004 mit WordPress. Im Laufe der Jahre hat er diverse Fachbücher und Fachartikel publiziert.

Verwandte Beiträge

15 Gedanken zu „WordPress 3.6: Umlaute im Titel ohne Plugin entschärfen“

  1. Yeah, endlich!!! Sehr sehr cool – und wieder ein Plugin gespart. Geht doch! 🙂

    (Die sollen endlich mal die Kommentar-Formatierungsleiste [wie hier] und Bilder-Fancybox standardmäßig einbauen – das wäre ebenfalls super 🙂 )

  2. Klasse !
    Ich hatte mich auch schon nach einer Lösung für dieses “Problem” umgesehen.
    Hat sich ja dann aber schon so gut wie erledigt 😉

  3. Für zukünftige Artikel ne feine Sache, aber wie schaut das mit bestehen Artikeln aus? Werden die mit dem Update auf 3.6 alle aktualisiert und meine Permalinks sind falsch? ^^

  4. Ich gehe davon aus, dass bestehende Artikel auf das neue Permalink-Format aktualisiert werden.

    Wie sieht es an der Datei mit Hooks oder Customizations aus? Habe WP Permalauts und weitere Sonderzeichen (é, è etc.) hinzugefügt (Pokémon ^^),

    Gibt es da irgendwo mehr Infos zu?

  5. Gut, dass ich gerade nochmal gegoogelt habe. Sonst hätte ich wahrscheinlich noch ein Plug-in installiert.
    Ich bekomme bei Seitenreport immer die Meldung, dass meine Sitemap ungültig wäre. Ich schätze mal, dass es bei mir an den fehlenden Umlauten liegt. Mal schauen, ob sich danach etwas tut.

Kommentare sind geschlossen.